it-swarm-ja.tech

IIS7アプリケーションプールフレームワークバージョン3.5がありません

IIS7で新しいアプリケーションプールを作成し、そのフレームワークバージョンに3.5を指定しようとしています。ただし、フレームワークバージョンのドロップダウンのオプションとして、「v2.0.50727」または「マネージコードなし」しかありません。

どうすればそれができ、どうすれば修正できますか?

3
AnthonyWJones

これは正しいです。

ボックスに.net3.5がインストールされている限り、.net 3.5Webアプリが実行されます。

「ASP.NET3.5、それはまだASP.NET 2.0コアの基本に基づいています。したがって、IISには新しいアプリケーションタイプ(ASP.NET 3.5用)はありません。」

ここから取得: リンクテキスト

11
Jimmie R. Houts

.NET 3.5のコアランタイムはまだv2.0.50727であるため、.NET3.5の個別のバージョンはありません。 .NET 3.5は、2.0ランタイムの上に階層化された単なる追加のクラスと新しいコンパイラです。 2.0を選ぶだけ

4
Kevin Dente

上記の2つの答えは正しいです。さらに、これは。NET 3.5(SP1)に「アップグレード」しない理由はありませんを意味することに注意してください。既存の.NET2.0コードに関する限り、このリリースは単なるサービスパック(正確には.NET 2.0 SP2)です。

3
John Saunders