it-swarm-ja.tech

pip.installが動作を停止しました:「要件<パッケージ>を満たすバージョンが見つかりませんでした」

私はいくつかの関連する質問を見てきました、そして私はそれらの推奨事項をすべて試しました:

  • アナコンダを使用しているため、3.7から3.6にダウングレードしました
  • Curlを使用してpipをアップグレードしました https://bootstrap.pypa.io/get-pip.py |須藤ニシキヘビ
  • Openssl(1.1.1)の最新バージョンをインストールしました
  • すべてのAnacondaライブラリを更新しました
  • 私はインターネットに接続しており(明らかに、ここに投稿しているため)、ファイアウォールの内側ではありません。

それでも、「pip install」または「pip install ==」を実行するたびに、次のエラーが発生します。

エラー:要件を満たすバージョンが見つかりませんでした(バージョン:なし)エラー:一致するディストリビューションが見つかりません

私はMac、Mojave v10.14.4を使用しています

最近、prodigy.aiをインストールしました。prodigy.aiは、多くのパッケージを(おそらく)古いバージョンに置き換えているようですが、この問題を解決する方法がわかりません。私が試していないのは、Anacondaをアンインストールして再インストールすることだけです。

これについて何か助けてくれてありがとう。

4
jsidell

はい、それは私にも起こりました。

この手順の一般的なケースは、パッケージ名を入力するときにtypoを作成していないかどうかを確認することです。

2
simhumileco