it-swarm-ja.tech

pip 9.0.1を9.0.3にアップグレードできません-要件はすでに満たされています

pip install --upgrade pipを使用してpipを更新しようとしていますが、同時に「要件を満たしました」エラーと「古いバージョン」メッセージが表示されます

$ pip install --upgrade pip
Requirement already up-to-date: pip in 
/Users/user/Envs/proj/lib/python2.7/site-packages
You are using pip version 9.0.1, however version 9.0.3 is available.
You should consider upgrading via the 'pip install --upgrade pip' 
command.

更新するにはどうすればよいですか?

29
Soundtemple

最近、Python.orgサイト TLSバージョン1.0および1.1のサポートを停止 。これは、直面している鶏と卵の問題を引き起こしている可能性があります。 pipを使用してpipwithoutをアップグレードしてみてください。

curl https://bootstrap.pypa.io/get-pip.py | python
111
Anupam

これらの2つのコマンドは私のために働いた:

curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py

その後:

python get-pip.py
8
paul

試してください:
右クリックAnacondaプロンプト(管理者として実行)

>> conda update pip

(それは私のために働いた)

4
OM Bharatiya

上記のカールの答えは私にはうまくいきませんでした。これは私のために働いた

Sudo python -m pip install --upgrade pip
2
swb