it-swarm-ja.tech

Viに代わるVim

みんな、viを実行するたびにLinuxコンソールエディターをviからvimに変更する方法を知っている人はいますか? UbuntuとFedora Coreを使用しています

29
Funky81

まず、適切なVimパッケージがインストールされていることを確認します。多くのシステムのデフォルトでは、機能的にはViに近い最小限のVimパッケージがインストールされます。

Red Hatベースのシステム(RHEL、CentOS、Fedora)では、たとえば、私がインストールしたCentOSシステムのvim拡張パッケージが必要です。

vim-common-7.0.109-4.el5_2.4z
vim-enhanced-7.0.109-4.el5_2.4z
vim-minimal-7.0.109-4.el5_2.4z

'common'には、すべてのVimパッケージで使用される共通ライブラリが含まれています。 'minimal'は、デフォルトでインストールされるプレーンなviエディター実行可能ファイルです。

Debianベースのシステム(Ubuntuなど)では、「vim」が必要です。例えば:

ii  vim                  2:7.2.079-1ubuntu5  Vi IMproved - enhanced vi editor
ii  vim-common           2:7.2.079-1ubuntu5  Vi IMproved - Common files
ii  vim-runtime          2:7.2.079-1ubuntu5  Vi IMproved - Runtime files
ii  vim-tiny             2:7.2.079-1ubuntu5  Vi IMproved - enhanced vi editor - compact version

これらはデフォルトでインストールされます。 Debian/Ubuntuでは、すべてのユーザーのデフォルトのシステムエディターを更新できます。

Sudo update-alternatives --config vi

選択メニューから目的のバージョンを選択します。ただし、vimパッケージのインストール後スクリプトは、これをすでに更新しているはずです。使用する --config editorシステム上のすべてのユーザーのデフォルトエディターを変更します(たとえば、Ubuntu 9.04の元のデフォルトはnanoです)。

最後に、ディストリビューションごとにユーザーごとに、ユーザープロファイルにエイリアスを設定します。たとえば、シェルがbashの場合は、〜username/.bashrcを編集します。

alias vi="vim"

また、システムのvimrc(通常は/ etc/vimrc)をチェックして、互換モードがオンになっているかどうかを確認することもできます。

set cp
set compatibility

上記のVimを使用してどのように処理したかに関係なく、Vimに旧式のViのように動作するように指示します。 Vimをより使いやすくするには、「nocp」または「nocompatibility」に変更します。

35
jtimberman

あなたの.bashrcで:

alias vi=vim
28
Al.

それがDebianまたはUbuntuシステムであり、この変更システムを広くしたい場合は、update-alternativesを使用する必要があります(--config editorオプションで指定し、ゴールデンにする必要があります)

10
mwalling

IDのみの変更が必要な場合、およびターミナルセッション内:AIの提案に従ってviをvimにエイリアスします。

マシンでシステム全体の変更が必要な場合は、/ usr/local/binでvimにソフトリンクします。

Sudo ln -s `which vim` /usr/local/bin/vi

注:プログラムは、viの代わりにcommand viまたは\viを実行することにより、viのエイリアスを無視できます。

9
user4358

一部のdistはvim:sの古い学校モードを使用しており、viのように動作します。

.vimrcに

set nocompatible

私はこれに何度か騙されました...

3
Johan

Debianシステムでは、デフォルトのvim-tinyを「vi」として実行すると、別のRCファイルが使用されます-/etc/vim/vimrc.tiny。

「vi」を「vim」のように機能させるには、/ etc/vim/vimrc.tinyを編集して次の行を変更します。

set compatible

読む:

set nocompatible
1
user22083

.profile on archlinux 使用 bash

if [ -f "/usr/bin/vim" ];
 alias vi="vim"
else
 alias vim="vi"
fi

export EDITOR=vim

したがって、 vim は常に適切に存在するか、または vi として存在します。

0
user373230

fish を使用する場合は、以下の行を~/.config/fish/config.fish

alias vi="vim"
0
Zhang Buzz