it-swarm-ja.tech

Linuxでは32ビットまたは64ビットを選択する必要がありますか?

私は現在4GBのRAMを備えているLinuxワークステーションを所有しており、近い将来8GBを使用する予定です。CPUはCore2Quad Q9550

Linuxの32ビットまたは64ビットのバリアントをインストールする必要がありますか?

18
Robert Munteanu

64ビットLinuxをインストールする必要があります。 32ビットカーネルが4GBを超えるアドレスを指定する方法はありますが、アプリケーションには3GBの制限があります。

18
D. Wroblewski

64ビットカーネルと32ビットディストリビューションを実行すると、PAEのパフォーマンスを低下させることなく、4GB以上のRAMにフルアクセスできます。これは私が自分のマシンで行うことです。 Debianには linux-image-AMD64 i386で利用可能です。残念ながら、Ubuntuにはありません。そこで独自のカーネルをコンパイルする必要があり、他のディストリビューションにパッケージがあるかどうかはわかりません。

そうは言っても、Skypeや一部のブラウザプラグインなどの32ビットのみのバイナリのハックに耐えられる限り、パフォーマンスが向上するため、新規インストールには64ビットをお勧めします。現在、RPMディストリビューションはこれをサポートしていますが、DebianとUbuntuはサポートしていませんが、現在作業中です マルチアーチサポート 現在、Ubuntu9.10で最初のリリースが予定されています。

5
TRS-80

私は64ビットバージョンをインストールし、場合によっては VirtualBox のようなものをインストールして、32ビットでのみ使用可能なソフトウェアが必要な場合に備えて32ビットバージョンを並行して実行できるようにします。

32ビットカーネルを使用して4GBを超えるメモリを使用するには、PAEのようないくつかのフープを飛び越えなければなりません。これは私見では避けたほうがよいでしょう。

4
Timo Geusch

32ビットは4GB未満しか使用できません単一プロセスの場合ですが、システム全体でそれ以上使用できます。 Linuxには、私が考えることができるほど多くのRAM)を必要とする非サーバーアプリケーションは多くありません。

PAE(Physical Address Extension)カーネルをインストールする必要があります。

Sudo sudo apt-get install linux-headers-server linux-image-server 

その後、再起動します。トップまたはフリーで実行すると、より多くのラムが必要です。デスクトップユーザーには32ビットをお勧めします。

4
Kyle Brandt

ここ はLinuxForumsの概要の1つです。

ニッチな作業をしたり、完全にコンパイルされた言語で書かれたツールを開発したりする場合は、躊躇します。 [〜#〜] ldc [〜#〜] のように、私が興味を持っているプロジェクトの多くは、64ビットをサポートし始めたばかりです。個人的には延期していますが、RAMも延期しているので、それは私にとって問題ではありません。

4
Nikhil Chelliah

ホームデスクトップ用に64ビット9.04を実行しています。私はこのマシンでかなり多くのことをします、そして私が遭遇する唯一の64ビット関連の問題は64ビットAdobeFlashの安定性の問題です。

3
Colin Pickard

64ビットを選択してください。 32ビットは約3.5GBのRAMにしかアクセスできず、互換性の問題のほとんどは解決されています。さらに簡単にするには、 bunt のような人気のあるディストリビューションを使用します。

2
Lucas Jones

8 GBをすべて自然に使用するには、64ビットバージョンをインストールする必要があります。