it-swarm-ja.tech

APTにインストールできるパッケージのバージョンを確認する方法

APTを使用すると、以下を使用してパッケージの特定のバージョンをインストールできます。

apt-get install package=1.0

しかし、あなたはできません

apt-get install package=1.*

それでは、どのバージョンが特定のリポジトリのpackage、または私の/etc/apt/sources.listのすべてのリポジトリで利用可能であるかをどうやって見つけることができますか?

62
Camilo Martin

補遺として

apt-cache madison <<package name>>

あなたのすべてのソースから利用可能なバージョンを一覧表示します。

apt-cache madison vim
   vim | 2:7.3.547-1 | http://debian.mirrors.tds.net/debian/ unstable/main AMD64 Packages
   vim | 2:7.3.429-2 | http://debian.mirrors.tds.net/debian/ testing/main AMD64 Packages
   vim | 2:7.3.429-2 | http://http.us.debian.org/debian/ testing/main AMD64 Packages
   vim | 2:7.3.429-2 | http://debian.mirrors.tds.net/debian/ testing/main Sources
   vim | 2:7.3.547-1 | http://debian.mirrors.tds.net/debian/ unstable/main Sources

madisonapt-cacheサブコマンドです、man apt-cacheは言います:

apt-cacheのmadisonコマンドは、Debianアーカイブ管理ツールmadisonの出力フォーマットと機能のサブセットを模倣しようとします。利用可能なバージョンのパッケージを表形式で表示します。オリジナルのマディソンとは異なり、APTがパッケージリストを取得したアーキテクチャ(APT :: Architecture)の情報のみを表示できます。

86
lornix

apt-cache show <Package>は、あなたのdebianインストールがインストールできるすべてのバージョンのパッケージの説明を示しています(すなわち、sources.listにリストされたリポジトリから入手可能なパッケージのキャッシュされたリストから)。だから私はあなたが(例えば)のような何かを試すことができると思います:

# apt-cache show package | grep Version
Version 1.0
Version 0.9-2squeeze1

apt-cache showは単なるバージョンよりもはるかに多くの情報をあなたに与えるでしょう。

23
Anil
apt-cache policy gdb

出力例:

gdb:
  Installed: 7.7.1-0ubuntu5~14.04.2
  Candidate: 7.7.1-0ubuntu5~14.04.2
  Version table:
 *** 7.7.1-0ubuntu5~14.04.2 0
        500 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/main AMD64 Packages
        100 /var/lib/dpkg/status
     7.7-0ubuntu3 0
        500 http://fr.archive.ubuntu.com/ubuntu/ trusty/main AMD64 Packages
        500 http://archive.ubuntu.com/ubuntu/ trusty/main AMD64 Packages

そのため、GDBには2つのバージョンがあります。

  • 7.7.1-0ubuntu5~14.04.2
  • 7.7-0ubuntu3

出力の意味

これを特に意図したコマンドは apt-show-versions です。あなたはしばしばそれをインストールしなければなりません、しかしそれからapt-show-versions -aを実行することができ、そしてそれはあなたにそれが見つけられることができるバージョン番号、ディストリビューション(すなわちテスト、安定版、不安定版、バックポートなど)を示します。インストールしたバージョンが最新であるかどうかを教えてください。

Apt-cacheほど多くの情報は得られませんが、正しいリポジトリから(aptitude/apt-get -tを使って)インストールすることも、正しいバージョン番号を使ってインストールすることもできるので、必要なものはほとんど得られます。あなたが書き留めたフォーム.

2
ShankarG