it-swarm-ja.tech

node_modules / rxjs / internal / types.d.ts(81,44):エラーTS1005: ';' Angular 6のインストール後に予期されるエラー

エラーが発生しました

node_modules/rxjs/internal/types.d.ts(81,44):エラーTS1005: ';'期待される。

Angular 6。

エラーを確認します。

ERROR in node_modules/rxjs/internal/types.d.ts(81,44): error TS1005: ';' expected.
node_modules/rxjs/internal/types.d.ts(81,74): error TS1005: ';' expected.
node_modules/rxjs/internal/types.d.ts(81,77): error TS1109: Expression expected.
127
SSP

この問題は、バージョンの不一致が原因で発生する場合があります。問題を解決するには、package.jsonファイルで次の変更を行う必要があります。

ステップ1package.jsonに移動し、"rxjs": "^6.0.0""rxjs": "6.0.0"に変更します

ステップ2プロジェクトでnpm installを実行します。

TypeScriptのバージョンを変更する必要はありません。 (鉱山:"TypeScript": "~2.7.2"

編集:rxjs-compatを使用している場合は、問題を修正するために以下を実行する必要もあります。 rxjs-compatバージョンを"rxjs-compat": "^6.2.2"から"rxjs-compat": "6.2.2"に変更します

これが役立つことを願っています!

341
TheParam

angular 6 [email protected]を使用して同じエラーが発生しましたが、rxjs @ 6.3.3にダウングレードしました。

9

package.jsonでいくつかの変更を行う必要があります

package.jsonに移動し、"rxjs": "^6.0.0""rxjs": "6.0.0"に変更します

次に、プロジェクトでnpm updateを実行します

7
Sachith

プロジェクトディレクトリに移動し、このコマンドを実行します

npm install [email protected] --save

6
shrikantbishoye

Rxjs-compatを使用している場合は、問題を修正するために以下を実行する必要もあります。からrxjs-compatバージョンを変更します

"rxjs-compat": "^6.2.2" 

"rxjs-compat": "6.2.2"

これは私のために働く

5
Tuts Dev

以前、@ TheParamの答えで問題を修正していましたが、最近糸を使い始めました。悲しいことに、私は同等の糸を見つけることができませんでした

nmp update

使ってみた

yarn upgrade

(それは上記のコマンドafaikと同等ではありませんが)、助けにはなりませんでした。

代わりに使用しました

yarn add [email protected]

そしてそれは働いた。 npmの場合の数秒と比較して、82秒というかなりの時間がかかりましたが、問題は修正されました。私のノード8.11.2とyarn 1.15.2

3
user3792812

次に示すように、ファイルを編集し、0の後の最終行にセミコロンを追加する必要がありました。

パス[project directory]/node_modules/rxjs/internalに移動し、ファイルtypes.d.tsを管理者として開き、ファイルの最後に移動してセミコロンを追加します。

元のコード:export declare type ObservedValueOf<O> = O extends ObservableInput<infer T> ? T : never;

変更されたコード:export declare type ObservedValueOf<O> = O; extends ObservableInput<infer T> ? T : never;

Package.jsonの「rxjs」を「^ 6.0.0」から「6.0.0」に変更して実行すると、うまく機能します

「npm i」

0
Menna Ramadan

それでも問題が解決しない場合は、package.jsonにアクセスしてください

  1. rxjsを削除し、rxjs-compatも追加します。「rxjs-compat」:「^ 6.4.0」から「rxjs-compat」:「6.4.0」、

  2. typscriptバージョンを2.8に変更します

  3. npm installを実行します

これはあなたのために働くでしょう!

0
Charuka Herath

同じ問題がありました。「rxjs」:「^ 6.0.0」から「rxjs」:「6.0.0」は機能しませんでした。 angular CLIを最後の安定版に更新する必要がありましたnpm install -g @angular/cliそして、プロジェクトを再生成します。

私の設定は次のとおりです。

Angular CLI: 7.3.6
Node: 10.15.3
OS: win32 x64
Angular: 7.2.9
0
walox

この問題は、インストールされているTypeScriptのバージョンが、インストールされているrxjsのバージョンと互換性がないために発生します。下記のTypeScriptのインストールは、既にインストールされているangularパッケージとTypeScriptの互換バージョンをインストールするのに役立ちました。以下のコマンドによる問題

npm install TypeScript 

これは私のために働いた

同じ問題があった

npm install [email protected] 

私の問題を解決しました

0
Rita Punjabi