it-swarm-ja.tech

Android St​​udio 3.2-com.Android.tools.build:aapt2:3.2.0-4818971が見つかりませんでした

Androidのアイコンパックを開発するためのチュートリアルに従っていたのですが、プロジェクトをインポートしたときにいくつかのエラーが発生し、ここで解決しました- Gradleバージョン4.6-出力設定時の絶対パスはサポートされていませんファイル名

そのエラーを解決した後、次のエラーがポップアップしました。

Could not find com.Android.tools.build:aapt2:3.2.0-4818971.
Searched in the following locations:

file:/C:/Users/Tomin Jacob/AppData/Local/Android/Sdk/extras/m2repository/com/Android/tools/build/aapt2/3.2.0-4818971/aapt2-3.2.0-4818971.pom

file:/C:/Users/Tomin Jacob/AppData/Local/Android/Sdk/extras/m2repository/com/Android/tools/build/aapt2/3.2.0-4818971/aapt2-3.2.0-4818971-windows.jar

file:/C:/Users/Tomin Jacob/AppData/Local/Android/Sdk/extras/google/m2repository/com/Android/tools/build/aapt2/3.2.0-4818971/aapt2-3.2.0-4818971.pom

file:/C:/Users/Tomin Jacob/AppData/Local/Android/Sdk/extras/google/m2repository/com/Android/tools/build/aapt2/3.2.0-4818971/aapt2-3.2.0-4818971-windows.jar

file:/C:/Users/Tomin Jacob/AppData/Local/Android/Sdk/extras/Android/m2repository/com/Android/tools/build/aapt2/3.2.0-4818971/aapt2-3.2.0-4818971.pom

file:/C:/Users/Tomin Jacob/AppData/Local/Android/Sdk/extras/Android/m2repository/com/Android/tools/build/aapt2/3.2.0-4818971/aapt2-3.2.0-4818971-windows.jar

https://jcenter.bintray.com/com/Android/tools/build/aapt2/3.2.0-4818971/aapt2-3.2.0-4818971.pom

https://jcenter.bintray.com/com/Android/tools/build/aapt2/3.2.0-4818971/aapt2-3.2.0-4818971-windows.jar

https://jitpack.io/com/Android/tools/build/aapt2/3.2.0-4818971/aapt2-3.2.0-4818971.pom

https://jitpack.io/com/Android/tools/build/aapt2/3.2.0-4818971/aapt2-3.2.0-4818971-windows.jar
Required by:
    project :licensing

URLを開こうとしたところ、最初の2つのURLからJAR(aapt2-3.2.0-4818971-windows.jar)およびJSON(aapt2-3.2.0-4818971.pom.json)ファイルをダウンロードできました。これらのファイルをどこかにコピーする必要がありますか?このエラーを解決するにはどうすればよいですか?

44
TomJ

ほとんどの場合、プロジェクトのbuild.gradleファイルにGoogleリポジトリがありません。以下に示すように、両方の場所にgoogle()を追加します。

buildscript {

    repositories {
        google()
        jcenter()
    }
    dependencies {
        classpath 'com.Android.tools.build:gradle:3.2.0'
    }
}

allprojects {
    repositories {
        google()
        jcenter()
    }
}
106
shagberg

両方の場所にgoogle()を追加することで問題を解決できました。

ファイル->プロジェクト構造->プロジェクト-> *ここで「、google()」を追加します

Androidプラグインリポジトリ

そして

デフォルトのライブラリリポジトリ

*

9
eurydice

4.6バージョンのgradleにアップグレードする場合。次のアップグレードも必要です。 Gradleプラグインリリースページ

1. Android St​​udio 3. +

4.6バージョンのgradleを使用するには、Android St​​udioバージョン3. +が必要です。ポスト最新リリースの時点では3.2.1でした。最新リリースは このページ で確認できます。

2. Gradleプラグイン3.1。+

Gradle-4.6をサポートするには、3.1。+ gradleプラグインが必要です。プロジェクトレベルbuild.gradleをチェックインします。

classpath 'com.Android.tools.build:gradle:3.2.1'

投稿時の最新バージョンは3.2.1でした。 最新リリースはこちら で確認できます。

3. Google Mavenライブラリを追加する

以下のコードのように、プロジェクトレベルのbuild.gradleにGoogle Mavenライブラリを追加する必要があります。

buildscript {
    repositories {
        google()
        ...
    }
    dependencies {
        classpath 'com.Android.tools.build:gradle:3.2.1'
        ...
    }
}

allprojects {
    repositories {
        google()
        ...
    }
}
6
Khemraj

関連するgradleファイルのBOTH位置に2つのgoogleを追加した後でも、まったく同じ問題に直面している人々のために。 Android Studio -> Preferences -> HTTP Proxyページを確認することをお勧めします。
「... JVMプロキシを127.0.0.1に設定しました」などの警告が表示される場合は、コンテキストに応じてvpn関連の問題を考慮する必要があります。
デスクトップがMacOSの場合、Network設定ページの[advance->proxy]タブに移動し、ncheckチェックボックスをすべてオンにします。
次の手順でIDEに戻ります。Android Studio->File->Invalidate Caches/Restart。その後、Android Studio -> Preferences -> HTTP Proxyページを再度確認します。以前の警告は表示されなくなります。もう一度実行します。

1
zionpi

モジュール:licensingの依存関係を確認し、そこでcom.Android.tools.build:aapt2:3.2.0(または"com.Android.tools.build:aapt2:3.2.0:windows")を使用します。これが最終バージョンです... 4818971バージョンには通常alphaプレフィックス/サフィックス(バージョン番号が間違っているようです)。リポジトリgoogle()も追加する必要があるかもしれません。通常、その依存関係が存在する必要があります。その依存関係を削除することは、別の可能なオプションかもしれません。

1
Martin Zeitler

クラスパスをからアップグレードして問題を解決しました

    'com.google.gms:google-services:4.0.0

    'com.google.gms:google-services:4.2.0'

お役に立てれば

0
Collins Kiprop