it-swarm-ja.tech

64ビットUbuntu 12.04に32ビットJava(OpenJDK)をインストールします

64ビットUbuntu 12.04でJuniper VPNを実行する必要があります。 openjdk-7-jreopenjdk-7-jdk、およびicedtea-7-pluginをインストールしました。ブラウザがJuniper VPNのインストールを促した後、「/ home/huangyun/.juniper_networks/network_connect」に正常にインストールされたことを確認します。

コマンドラインからFirefoxを開き、ログを確認します。

Launching "/usr/lib/jvm/Java-6-openjdk-AMD64/jre/bin/Java" "-classpath" "/home/huangyun/.juniper_networks/network_connect/NC.jar" "NC" "-h" "extranet.scei.a-star.edu.sg" "-L" "0" "-l" "0" "-n" "" "-t" "" "-x"

上記のコマンドを手作業で実行します。

$ Java -classpath ~/.juniper_networks/network_connect/NC.jar NC -h extranet.scei.a-star.edu.sg -L 0 -l 0 -n "" -t "" -x
Failed to load the ncui library.
Quitting.

ファイルlibncui.soをチェックすると、.soファイルが32ビットバージョンであることがわかりました。

$ file libncui.so 
libncui.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, stripped

32ビットの.soファイルを64ビットに再コンパイルできないため、64ビットUbuntu 12.04に32ビットJavaをインストールする必要があると思います。方法を教えてください。ウェブを検索しましたが、ほとんど情報が見つかりません。

11
Yun Huang

OpenJDKのバグのため、ジュニパーはOracle Javaを必要としていました。

参照: https://github.com/flexiondotorg/oab-Java6

javaをインストールします。

3
senthilkumar

元の質問に答えるには:

12.04および12.10では、apt-getの実行時にパッケージ名に「:i386」を追加することにより、AMD64にi386パッケージをインストールできます。したがって、たとえば、AMD64 Ubuntu 12.04 Live CDを実行しているときに、次を実行しました。

Sudo apt-get remove firefox openjdk-6-jdk icedtea-6-plugin
Sudo apt-get install firefox:i386 openjdk-6-jdk:i386 icedtea-6-plugin:i386

そして、VPNに正常にログインできます。

12.04以降、Juniper VPN willはOpenJDK 6ですぐに使用できますが、i386でのみ機能します。 icedteaプラグインに bug があり、以前は機能していませんでした。これがi386 Ubuntu 12.04 Live CDを使用して修正されることを確認しました。

AMD64 Oracle JDKが機能していることに驚いています。ただし、私はまだ自分でテストしていませんが、実行したらこの回答を更新します。現在実行しているパッケージを正確に確認できると便利です。

接続するVPNサーバーで構成されている場合とされていない場合がある、ホストチェッカーと呼ばれるJuniper VPNログインプロセスのオプション部分があることに注意してください。 Windowsコンピューターにセキュリティポリシーを適用しますが、使用しているOSを確認するにはLinuxで実行する必要があります。これは、異なる人々からの成功の異なる報告をもたらす可能性があります。参考までに、私が使用しているVPNでは、ホストチェッカーが有効になっています。

元の質問では、Java 7パッケージをインストールしていると述べていますが、ログにはFirefoxでJava 6を使用していることが示されています。複数のJDKがインストールされている場合、使用しているJDKを明確にする必要があります。

参考までに、Juniper VPNのUbuntuフォーラムには、非常に長期にわたる thread もあります。

更新

AMD64 Oracle JDKをテストしましたが、動作しません。したがって、私の知る限り、i386バージョンのOracle JDKまたはOpen JDKをインストールすることが、それを機能させる唯一の方法です。

18
David Edwards

ここの手順を使用して: http://www.rz.uni-karlsruhe.de/~iwr91/juniper/ Ubuntu 12.04で実行されているjuniper VPNがあります次の3つのライブラリを除き、32ビットソフトウェアがインストールされていない64ビット:

Sudo apt-get install libc6-i386 lib32z1 lib32nss-mdns

--noxオプション(GUIなし)を使用してjnc Perlスクリプトを起動します。これは素晴らしい動作で、毎日使用しています。

最初にFirefox 64ビットを使用して証明書ファイルをダウンロードしました。[ツール]> [PageInfo]> [セキュリティ]> [証明書の表示]> [詳細]> [エクスポート]

それ以来、同じことを行うこのスクリプトを見つけました: https://github.com/udomsak/juniper-ncui/blob/master/getx509certificate.sh

私の特定の構成ファイルには、ホスト、ユーザー、レルム、および証明書ファイルが必要でした。あなたとは違うかもしれません。

Certfileの場所の構成にはフルパス名が必要でした。〜は/ home/usernameに展開されませんでした